You're blocking ads, which pay for BlenderNation. Read about other ways to support us.

Supporting add-ons for both 2.7 & 2.8

1

Patrick W. Crawford writes:

Blender 2.8 is in beta, and with add-on's being updating to be compatible, the question arises - "How do I, as an add-on developer, maintain ongoing 2.7 and 2.8 support?"

This live-streamed demo and supporting resource page cover some of the best practices and examples for how to avoid maintaining separate 2.7 vs 2.8 codebases. It furthermore stresses the importance of keeping longer term support for your add-ons with minimal developer overhead. Here's a sample success story: an add-on .zip file can be installed and work perfectly fine on any version of Blender between 2.72 (released in 2017) up through the latest build of 2.80 (and everything in the middle!). If you can't say the same for your own code, then this is the guide for you.

See the World Blender Meetup Day (March 16, 2019) live stream here:

Check out more details on the resource page here

Patrick (a.k.a TheDuckCow)

About Author

Patrick Crawford

Patrick (TheDuckCow) is the software engineer and digital artist behind Moo-Ack! Productions, and blender user since 2010. From open source blender addons to animated music videos to mobile apps for nonprofits, Patrick loves to create content and value for others while giving back to the community. He is the developer for MCprep & Pro Lighting Studio, and additionally works as a tools/pipeline developer for Theory Animation. He is also the managing member for Deverse, creating apps for social organizations.

1 Comment

  1. I hope in the final version of 2.8 the icons are going to be fixed, right now is everything so confusing, the icons are no clear.

Leave A Reply

To add a profile picture to your message, register your email address with Gravatar.com. To protect your email address, create an account on BlenderNation and log in when posting a message.