Stained: Level Editing Video

The Stained team has released a video showing their level editing workflow. The game is designed in Blender (2.49!), and exported to Ogre3D.


It looks like you're using an ad blocker. I really need the income to keep this site running, so please enable advertisements on BlenderNation, or leave me a small donation. Everything helps!

Thanks!
  • Talha Lodhi

    2.49!!!! why?

    • Radekgfx

      Because 2.49 is faster in terms of using and workflow (from my experience).

  • Sixstringbass

    Ah… The “Ambient Mallet” Sequence from NI’s FM8 synthie ;)
    Nice Sound.
    Nice video btw.
    And yes… why Blender 2.49?

  • http://MacroManJr.blogspot.com/ Brian Lockett

    Some folks like Blender 2.49.  And I’ve even seen some folks who just oersonally prefer the original layout they’re more accustomed to in Blender 2.49 than in Blender 2.5.  Nothing wrong with that.  I see no reason to nag anyone about it. lol  Hey, it’s a free option.  I even use Blender 2.49 every now and then.  There’s still a handful of features that are more stable on 2.49 than currently in Blender 2.5/2.6, and perhaps most of all, there are some very useful scripts that have yet to have make it to 2.5x/2.6x yet.  This is constantly changing over time, of course, but still, it’s not weird for someone to have Blender 2.49 an available option in one’s toolset.  If an option works for you and you just prefer it, go for it.  But hey, as long as the result are good, I don’t care if you used Blender 2.30!

    • http://MacroManJr.blogspot.com/ Brian Lockett

      Thanks for sharing that, Stained team.  I always like watching the making of games.  :)

      • Sushil

        Pleasure is mine! It took us long time almost 2 years to reach this level with blender, and we are hoping that the level editor will prove useful. 

  • Hivemind

    You need a stable version for production work. Blender 2.5 had been unstable for a long time and therefore no OGRE exporter existed for it. I guess it would have meant some extra work for them to switch the version later. 

    • Sushil

      Yes you are right. 

  • Wasamonkey

    In a production environment it’s not uncommon for the software used to become quite dated, and updating the software may cause breaks in the pipeline.

  • Sushil

    Thank you all! 

    Now why Blender 2.49? 

    We are settle with blender 2.49 so don’t want to change now. May be for our next game we can think about upgrading our tools. 
    When I started building this pipeline blender 2.49 was latest and  we have all script (python) set up in there. There are many script we use internally (small python scripts actually which makes our life easier) few of them don’t like newer version of blender (might be some changes to blender python API) so they need to be upgrade. Right now we don’t have time and energy to focus on that as our work is getting done. 

    Do you think the level editing is easy enough ?

    • chromemonkey

      I have read comments about pipelines a lot but I have never seen a guide for how to program one.  Are there any good tutorial resources or how-to guides for pipeline construction, is it more like nodes or more like python scripts?

      • Nick Rishel

         Pipelines, to my understanding, refers to how you use parts of programs in a sequence to accomplish work. For instance: Blender to model -> Blender to texture -> Maya to animate. That might not be 100% correct but it’s what I’ve derived from context clues.

  • Santop

    With such an open, customizable, environment it’s a shame blender is not used more often in this field…kudos to you Stained devs :)

  • mcbeth

    I too am doing a hobby game and use a 2.44 build for animation (in this project)  chiefly because some of my animation assets suffer severe gimbal locking issues if I edit them in 2.49… they work fine untouched in 2.49 though…….also I dont like the ogre 2.56 exporter, feels like more work to me, also I still have 2.61 merely because I find the inset extrude addon more intuitive then the new built in one in 2.63………….. 2.49 still have handy scripts that never got ported up e.g there is one brilliant one that generates different types of swords ……some of u people are “bandwagonist” that too often miss the forests for the trees ….there are old versions that still have there uses for example “passing” old 2.4x blend files through 2.55 will correct backward compatibility issues in a lot of cases for use with 2.55+ versions.

    just saying

  • realaxis

    There is a new game play trailer released for stained…
    http://www.youtube.com/watch?v=IVJXg2X6I8A